/ / Wordpress плъгин: Как да зависим от други плъгини? - css, wordpress, twitter-bootstrap, плъгини

Wordpress плъгин: Как да зависим от други плъгини? - css, wordpress, twitter-bootstrap, плъгини

Пиша проста приставка за wordpress(всъщност джаджа, пакетирана като приставка, поради причини). Аз използвам bootstrap за стил widget, защото причини. Сега проблемът е, че трябва да включа bootstrap по плъгина или да зависи от друга приставка (например https://wordpress.org/plugins/wordpress-bootstrap-css/). Първият е лесен, но не прекалено приятен начин да го направите. Втората, в която всъщност нямам никаква представа. Намерих някои приставки (като Plugin-Dependecies), които биха могли да бъдат използвани за него, но бих искал да го направя без мета-плъгина.

Има ли начин плъгинът да зависи от друга приставка, която не е в комплект? Ако да, как трябва да го направя?

Или ако има по-добър начин да се направи стилинг, какво би било това?

Благодаря предварително.

Отговори:

0 за отговор № 1

Виж това WordPress Plugin зависимости, Може да ви помогне.