/ / ZXing.Net.Mobile error de actualización en Android - xamarin, xamarin.android, zxing

Accidente de actualización de ZXing.Net.Mobile en Android - xamarin, xamarin.android, zxing

Necesito ayuda con el componente ZXing.Net.Mobile (biblioteca de escaneo de códigos de barras).

Las últimas versiones producen un error de tiempo de ejecución para el dispositivo Galaxy Ace 2 (API 10), no solo en mi aplicación, sino también en la muestra incluida con la biblioteca.

Me gustaría saber si esto es un error o solo una limitación de la API.

Versión probada: 2.0.4.17. Puedes probar la muestra.

Gracias.

Respuestas

1 para la respuesta № 1

Esta fue una limitación de API. Como puedes ver en esto enlazar la versión del escáner ZXing era incompatible con algunos dispositivos.

Afortunadamente, su creador lo resolvió y lanzó una nueva versión compatible con Android 2.3.