/ / Erreur de cadre Rails 4 + Zurb Foundation 5 - ruby-on-rails-4, zurb-foundation

Erreur de cadre Rails 4 + Zurb Foundation 5 - ruby-on-rails-4, zurb-foundation

essayer d'utiliser le framework Zurb Foundation 5 avec Rails 4.2.1 comme indiqué dans les tuts (http://www.gotealeaf.com/blog/rails-and-foundation-part-1/ ) Je reçois l'erreur suivante ..

Invalid CSS after "...ules: $modules ": expected "}", was "!global;"

dans mon fichier de gemme j'ai demandé les gemmes:

gem "rails", "4.2.1"
gem "sass-rails"
gem "foundation-rails"
...

dans mes actifs / stylesheets / application.css

 *= require_tree .
*= require_self
*= require foundation_and_overrides

dans mes actifs / javascripts / application.js

//= require jquery
//= require jquery_ujs
//= require foundation
//= require turbolinks
//= require_tree .
$(function(){$(document).foundation();});

c est mon premier essai pour utiliser Foundation (jusque-là j'utilisais Bootstrap ..) il ne semble pas si simple que Bootstrap3 + RAilS .. ou quelque chose manque dans les tuts ...

Réponses:

1 pour la réponse № 1

résolu en utilisant le dernier bijou

https://github.com/zurb/foundation/issues/6148

et en spécifiant

gem "foundation-rails", "5.4.5"

dans le Gemfile