/ / ज़ेंड फ्रेमवर्क के पुराने संस्करण को स्थापित करना? - PHP, ज़ेंड-फ्रेमवर्क

ज़ेंड फ्रेमवर्क के पुराने संस्करण को स्थापित करना? - PHP, ज़ेंड-फ्रेमवर्क

मैं अपने लिनक्स फेडोरा 14 पर PHP 5.2.6 के साथ ज़ेंड फ्रेमवर्क 1.5.2 स्थापित करना चाहता हूं।

मुझे ज़ेंड फ्रेमवर्क 1.5.2 रिलीज मिला

 http://framework.zend.com/download/archives

अब मुद्दा यह है कि, मुझे कोई भी इंस्टॉल इंस्टॉल नहीं दिख रहा हैफ़ाइल ज़ेंड फ्रेमवर्क फ़ोल्डर। अगर मैं एसएसएच / पुटी में जेएफ का उपयोग करता हूं तो यह ज़ेन फ्रेमवर्क का नवीनतम संस्करण 1.5.2 नहीं स्थापित करेगा और यह PHP को नवीनतम संस्करण में अपडेट करेगा। हालांकि मैं php को अपडेट नहीं करना चाहता क्योंकि मेरे कोड काम करना बंद कर देंगे, और नवीनतम जेडएफ पुराने जेडएफ की संरचना से मेल नहीं खाता है।

एक नौसिखिया के लिए, क्या आप समझा सकते हैं कि ZF 1 को कैसे इंस्टॉल करें।5.2 वहां फाइल बनाने के बिना, या मैं सिर्फ अंधा हूं और यह वहां है? यह कहता है कि इसे कॉपी करें और इसे अपने include_path में शामिल करें। मेरी ज़ेंड लाइब्रेरी /var/www/vhosts/mysite.com/httpdocs/library में है, मेरी php.ini फ़ाइल /etc/php.ini में है।

मैंने php.ini के include_path में "/var/www/vhosts/mysite.com/httpdocs/library" शामिल किया और सर्वर को पुनरारंभ किया। जब मैं इंडेक्स पेज लोड करने का प्रयास करता हूं तो यह मुझे एक त्रुटि दे रहा है। (2 मिनट में पोस्ट होगा)।

उत्तर:

जवाब के लिए 2 № 1

ज़ेंड फ्रेमवर्क इंस्टॉलेशन मूल रूप से आपके सर्वर पर फ़ाइलों और फ़ोल्डर्स का मुकाबला कर रहा है और आपके एप्लिकेशन में इस फ़ोल्डर को इंगित करता है, इसमें include_path भी शामिल है