/ / रेल 4 + ज़र्ब फाउंडेशन 5 फ्रेमवर्क त्रुटि - रूबी-ऑन-रेल -4, ज़र्ब-फाउंडेशन

रेल 4 + ज़र्ब फाउंडेशन 5 फ्रेमवर्क त्रुटि - रूबी-ऑन-रेल -4, ज़र्ब-फाउंडेशन

टट्स में बताए गए ज़र्ब फाउंडेशन 5 फ्रेमवर्क डब्ल्यू रेल 4.2.1 का उपयोग करने की कोशिश कर रहा है (http://www.gotealeaf.com/blog/rails-and-foundation-part-1/ ) मुझे निम्नलिखित त्रुटि मिलती है ..

Invalid CSS after "...ules: $modules ": expected "}", was "!global;"

मेरे मणि फ़ाइल में मैंने रत्नों से अनुरोध किया:

gem "rails", "4.2.1"
gem "sass-rails"
gem "foundation-rails"
...

मेरी संपत्ति / स्टाइलशीट / application.css में

 *= require_tree .
*= require_self
*= require foundation_and_overrides

मेरी संपत्ति / जावास्क्रिप्ट / application.js में

//= require jquery
//= require jquery_ujs
//= require foundation
//= require turbolinks
//= require_tree .
$(function(){$(document).foundation();});

यह फाउंडेशन का उपयोग करने की मेरी पहली कोशिश है (तब तक मैं बूटस्ट्रैप का उपयोग कर रहा था ..) यह बूटस्ट्रैप 3 + राइल्स के रूप में इतना आसान नहीं लगता .. या टट्स में कुछ गुम है ...

उत्तर:

उत्तर № 1 के लिए 1

नवीनतम मणि का उपयोग कर हल किया

https://github.com/zurb/foundation/issues/6148

और निर्दिष्ट

gem "foundation-rails", "5.4.5"

Gemfile में