/ / रेल और उबंटू विभिन्न रूबी संस्करणों की रिपोर्टिंग - रूबी-ऑन-रेल, रूबी, उबंटू -12.04, शेफ

रेल और उबंटू विभिन्न रूबी संस्करणों की रिपोर्टिंग - रूबी-ऑन-रेल, रूबी, उबंटू -12.04, शेफ

जब मैं नए सर्वर बनाने के लिए वग्रेंट और शेफ का उपयोग करता हूंमैं विकास कर रहा हूँ मैं रेल पर रूबी पर शुरू करना चाहता हूं इसलिए मैं एक सर्वर स्थापित कर रहा हूं। सब कुछ काम कर रहा है लेकिन उबंटू और रेल विभिन्न रूबी संस्करणों की रिपोर्ट कर रहे हैं।

उबंटू 12.04: रूबी-वी = रूबी 1.9.3 पी 0 (2011-10-30 संशोधन 33570) [x86_64-linux]
रेल = 1.8.7 (x86_64-linux)

मैं सिस्टम पर रूबी 1.8.7 नहीं चाहता हूं लेकिन मैं इससे छुटकारा नहीं पा सकता हूं। क्या डिफ़ॉल्ट रूबी संस्करण सेट करने के लिए वैसे भी है?

मैं शीर्ष उपयोग आरवीएम या इसी तरह के नहीं चाहता हूँ।

उत्तर:

जवाब के लिए 0 № 1

इसे इस्तेमाल करे aptitude purge ruby

और उसके बाद नवीनतम संस्करण या संस्करण जो आप चाहते हैं स्थापित करें

इस पोस्ट में स्टैक ओवरफ्लो में आया था मैं उबंटू पर रूबी 1.9 डिफ़ॉल्ट रूबी कैसे बना सकता हूं?


जवाब के लिए 0 № 2

यह चाल है।

https://github.com/royratcliffe/VagrantBaseBoxes