/ / रुबी 2.2.2 से रूबी 2.1.6 तक डाउनग्रेडिंग - रूबी-ऑन-रेल, रूबी

रुबी 2.2.2 से रूबी 2.1.6 तक डाउनग्रेडिंग - रूबी-ऑन-रेल, रूबी

मैं एक शुरुआती रेल डेवलपर हूं और जब मैंने कमांड प्रॉम्प्ट पर "रेल सर्वर" करने की कोशिश की, तो मैंने इस समस्या का सामना करना जारी रखा, मुझे एक त्रुटि मिल रही है:

"में" आवश्यकता है ": ऐसी फ़ाइल लोड नहीं कर सकता - नोकोगिरी / नोकोगिरी (लोडरर)"

मैंने ऑनलाइन खोज की और स्पष्ट रूप से नोकोगिरी वर्तमान में रूबी 2.2.2 (संस्करण जो मैं वर्तमान में उपयोग कर रहा हूं) के लिए समर्थित नहीं है।

मैं वर्तमान में विंडोज 8.1 पीसी पर रुबी 2.2.2, रेल 4.2.3, और मणि बनाम 2.4.8 में काम कर रहा हूं।

क्या ऐसा कुछ है जो मैं इसे रोकने के लिए कर सकता हूंमुसीबत? अभी, मैं सोच रहा हूं कि सबसे आसान तरीका सिर्फ रूबी 2.1.6 में डाउनग्रेड करना होगा और वहां से जाना होगा। क्या कोई मुझे यह बताने के लिए तैयार होगा कि मैं ऐसा कैसे करूं? मैंने रूबी इंस्टालर का उपयोग किया लेकिन मुझे नहीं पता कि रूबी इंस्टॉल करना है या नहीं रूबी 2.2.2 के शीर्ष पर 2.1.6 मेरे सिस्टम में कुछ भी गड़बड़ कर देगा। क्या स्वचालित रूप से कुछ भी डाउनग्रेड करने का कोई तरीका है?

अग्रिम धन्यवाद और अगर डाउनग्रेडिंग के अलावा कोई और आसान तरीका है तो कृपया मुझे बताएं!

अनुलेख मैंने मणि संस्करण को डाउनग्रेड करने का प्रयास किया और फिर मुझे एहसास हुआ कि यह वास्तव में रूबी संस्करण को नहीं बदलता है।

उत्तर:

जवाब के लिए 0 № 1

आप फ़ोल्डर 2.2.2 को हटा सकते हैं और पुराना संस्करण पुनः स्थापित कर सकते हैं। केवल पैथ वैरिएबल को दोबारा जांचें यदि यह सही ढंग से पुनः स्थापित रूबी पथ को इंगित करता है।