/ / हरोकू रन डीबी: माइग्रेट रेक एब्रोस्ड के रूप में विफल रहता है - रूबी-ऑन-रेल्स, हरोकू, डबस्मेट

Heroku रन डीबी: माइग्रेट रैक निरस्त के रूप में विफल - रूबी-ऑन-रेल, heroku, dbmigrate

मेरे नवीनतम कोड हेरोकू को धकेलने के बाद तालिकाओं में परिवर्तन नहीं हुआ। जब मैं "हेरोकू रेक डीबी: माइग्रेट करता हूं" चला जाता हूं, तो मैं रेक निरस्त हो जाता हूं

इसके सिंटैक्स त्रुटि कहते हैं, लेकिन मैं नहीं कर सकता जहां त्रुटि है

syntax error on line 4, col 586: `      state: ["σלקµ╡╖Θבף","Θ¥עµú«τ£ל","σ▓⌐µיכτ£ל","σ««σƒמτ£ל","τºכτפ░τ£ל","σ▒▒σ╜óτ£ל","τªןσ│╢τ£ל","Φל¿σƒמτ£ל","µáדµ£¿τ£ל","τ╛ñΘª¼τ£ל","σƒ╝τמיτ£ל","σםדΦסיτ£ל","µ¥▒Σ║¼Θד╜","τÑ₧σÑטσ╖¥τ£ל","µצ░µ╜ƒτ£ל","σ»לσ▒▒τ£ל","τƒ│σ╖¥τ£ל","τªןΣ║ץτ£ל","σ▒▒µó¿τ£ל","Θץ╖Θחמτ£ל","σ▓נΘר£τ£ל","Θ¥שσ▓íτ£ל","µה¢τƒÑτ£ל","Σ╕יΘחםτ£ל","µ╗כΦ│אτ£ל","Σ║¼Θד╜σ║£","σñºΘר¬σ║£","σו╡σ║½τ£ל","σÑטΦי»τ£ל","σעלµ¡לσ▒▒τ£ל","Θ│Ñσןצτ£ל","σ│╢µá╣τ£ל","σ▓íσ▒▒τ£ל","σ║דσ│╢τ£ל","σ▒▒σןúτ£ל","σ╛│σ│╢τ£ל","Θªשσ╖¥τ£ל","µה¢σ¬¢τ£ל","Θ½רτƒÑτ£ל","τªןσ▓íτ£ל","Σ╜נΦ│אτ£ל","Θץ╖σ┤מτ£ל","τזךµ£¼τ£ל","σñºσטזτ£ל","σ««σ┤מτ£ל","Θ╣┐σונσ│╢τ£ל","µ▓צτ╕הτ£ל"]"
/usr/local/lib/ruby/1.9.1/syck.rb:135:in `load"
/usr/local/lib/ruby/1.9.1/syck.rb:135:in `load"
/usr/local/lib/ruby/1.9.1/syck.rb:146:in `block in load_file"
/usr/local/lib/ruby/1.9.1/syck.rb:145:in `open"
/usr/local/lib/ruby/1.9.1/syck.rb:145:in `load_file"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/base.rb:172:in `load_yml"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/base.rb:157:in `load_file"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/base.rb:15:in `block in load_translations"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/base.rb:15:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/base.rb:15:in `load_translations"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/simple.rb:57:in `init_translations"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/simple.rb:71:in `lookup"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/base.rb:26:in `translate"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/fallbacks.rb:44:in `block (2 levels) in translate"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/fallbacks.rb:43:in `catch"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/fallbacks.rb:43:in `block in translate"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/fallbacks.rb:42:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n/backend/fallbacks.rb:42:in `translate"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n.rb:156:in `block in translate"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n.rb:152:in `catch"
/app/vendor/bundle/ruby/1.9.1/gems/i18n-0.6.1/lib/i18n.rb:152:in `translate"
/app/vendor/bundle/ruby/1.9.1/gems/activerecord-3.1.1/lib/active_record/railtie.rb:102:in `block in <class:Railtie>"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/lazy_load_hooks.rb:34:in `call"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/lazy_load_hooks.rb:34:in `execute_hook"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/lazy_load_hooks.rb:43:in `block in run_load_hooks"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/lazy_load_hooks.rb:42:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/lazy_load_hooks.rb:42:in `run_load_hooks"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/application/finisher.rb:56:in `block in <module:Finisher>"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/initializable.rb:30:in `instance_exec"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/initializable.rb:30:in `run"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/initializable.rb:55:in `block in run_initializers"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/initializable.rb:54:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/initializable.rb:54:in `run_initializers"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/application.rb:96:in `initialize!"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/railtie/configurable.rb:30:in `method_missing"
/app/config/environment.rb:5:in `<top (required)>"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:223:in `block in load_dependency"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:640:in `new_constants_in"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:223:in `load_dependency"
/app/vendor/bundle/ruby/1.9.1/gems/activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `require"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/application.rb:83:in `require_environment!"
/app/vendor/bundle/ruby/1.9.1/gems/railties-3.1.1/lib/rails/application.rb:193:in `block (2 levels) in initialize_tasks"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `call"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:205:in `block in execute"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:200:in `execute"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:158:in `block in invoke_with_call_chain"
/usr/local/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:176:in `block in invoke_prerequisites"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:174:in `invoke_prerequisites"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:157:in `block in invoke_with_call_chain"
/usr/local/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:151:in `invoke_with_call_chain"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/task.rb:144:in `invoke"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:116:in `invoke_task"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `block (2 levels) in top_level"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `each"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:94:in `block in top_level"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:88:in `top_level"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:66:in `block in run"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:133:in `standard_exception_handling"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/lib/rake/application.rb:63:in `run"
/app/vendor/bundle/ruby/1.9.1/gems/rake-0.9.2.2/bin/rake:33:in `<top (required)>"
/app/vendor/bundle/ruby/1.9.1/bin/rake:19:in `load"
/app/vendor/bundle/ruby/1.9.1/bin/rake:19:in `<main>"
Tasks: TOP => db:version => environment

किसी भी विचार समस्या क्या है?

उत्तर:

उत्तर № 1 के लिए 4

मैं बस उसी स्थिति में भाग गया

/usr/local/lib/ruby/1.9.1/syck.rb:135:in `लोड”: लाइन 4 पर वाक्यविन्यास त्रुटि, कॉल 586:

लाइन 4 पर सिंटैक्स त्रुटि, कर्नल 586: `राज्य: [ "北海道", "青森 県", "岩手 県", "宮城 県", "秋田 県", "山形 県", "福島 県", "茨城 県", "栃 木 県", "群 馬 県", "埼 玉 県", "千葉 県", "東京 都", "神奈川 県", "新潟 県", "富山 県", "石川 県", "福井 県", "山 梨 県", "長野 県", "岐阜 県", "静岡 県", "愛 知 県", "三重 県", "滋 賀 県", "京都 府", "大阪 府", "兵 庫 県", "奈良 県", "和 歌 山 県", "鳥取 県", "島 根 県", "岡山 県", "広 島 県", "山口 県", "徳 島 県", "香 川 県", "愛媛 県", "高 知 県", "福岡 県", "佐賀 県", "長崎 県", "熊 本 県", "大分 県", "宮 崎 県", "鹿 児 島 県", "沖 縄 県"] "

मेरे कुछ स्थानीय / tmp / संपत्ति बायनेरिज़ से मेल खाते हैंजीआरपी बयान। मैंने "heroku run grep -R" स्थिति: "*" चलाई और पाया कि फ़ाइल "विक्रेता / बंडल / रूबी / 1.9.1 / जवाहरात / faker-1.1.0 / lib / स्थानों / ja.yml" ने मेरी समस्या रेखा से मिलान किया । मेरे अंत में ठीक काम करता है, लेकिन जाहिर है कि Faker रत्न Heroku पर एक समस्या है।