/ / रेल 2.3.8 + actionwebservice + रूबी 1.9.2 समस्या - रूबी-ऑन-रेल, रूबी

रेल 2.3.8 + actionwebservice + रूबी 1.9.2 समस्या - रूबी-ऑन-रेल, रूबी

हैलो मैं "रेल 2.3 का उपयोग करने की कोशिश कर रहा हूँ।8 + actionwebservice। रूबी 1.8.7 के साथ यह ठीक है, लेकिन जब मैं 1.9.2 पर स्विच करता हूं तो मुझे अगली त्रुटि होती है । आरवीएम / रत्न / रूबी-1.9.2-पी 180 @ रेल 2 / रत्न / सक्रिय-समर्थन-2.3.8 / lib / active_support / निर्भरता.आरबी: 156: 'आवश्यकता' में: लोड करने के लिए ऐसी कोई फ़ाइल नहीं - साबुन / आरपीसी / ड्राइवर (MissingSourceFile)

रत्न:

source "http://rubygems.org"
gem "rails", "2.3.8"
gem "sqlite3-ruby", :require => "sqlite3"
gem "mysql2"
gem "athlite-actionwebservice", :require => "actionwebservice", :git => "git://github.com/athlite/actionwebservice.git"

मणि-वी 1.8.6

धन्यवाद

उत्तर:

उत्तर № 1 के लिए 1

रूबी 1.8 में उपलब्ध साबुन चालक को रूबी 1.9 में हटा दिया गया है

आपको इस जवाब में उल्लिखित रूप में रूबी 1.9 के लिए साबुन बनाने की आवश्यकता होगी: रुबी 1.9.2 में एसओएपी और अन्य मानक पुस्तकालयों का उपयोग करना