/ ubuntu 11.10 में वेटर स्थापित करने में त्रुटि

ubuntu 11.10 में वेटर स्थापित करने में त्रुटि - रूबी, उबंटू, रूबीगेम्स, वॉटर-वेबड्राइवर

उबंटू के नवीनतम संस्करण में रूबी ubuntu rubygems wati स्वचालन परीक्षण उपकरण वियर।

मैंने माणिक के नवीनतम संस्करण को प्राप्त करने के लिए एक sudo apt-get install रूबी किया, फिर मैंने Rubygems स्थापित किया और वातिर स्थापित करने की कोशिश की, लेकिन मुझे यह त्रुटि मिल रही है। यह रूबी 1.8.7 का उपयोग कर रहा है

मैं भी माणिक और माणिक रत्न को हटाने और पुनः स्थापित करने की कोशिश कर रहा हूं, लेकिन त्रुटि संदेश अभी भी होता है।

क्या कोई मुझे बता सकता है कि क्या गलत है?

root@kelley-VirtualBox:/home/kelley# gem -v
bash: /usr/bin/gem: No such file or directory
root@kelley-VirtualBox:/home/kelley# sudo apt-get install rubygems
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
libtcltk-ruby1.8
Use "apt-get autoremove" to remove them.
The following NEW packages will be installed:
rubygems
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/425 kB of archives.
After this operation, 4,166 kB of additional disk space will be used.
Selecting previously deselected package rubygems.
(Reading database ... 157806 files and directories currently installed.)
Unpacking rubygems (from .../rubygems_1.7.2-1_all.deb) ...
Processing triggers for man-db ...
Setting up rubygems (1.7.2-1) ...
root@kelley-VirtualBox:/home/kelley# gem list

*** LOCAL GEMS ***


root@kelley-VirtualBox:/home/kelley# gem install watir
Building native extensions.  This could take a while...
ERROR:  Error installing watir:
ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 extconf.rb
checking for strncpy_s()... no
creating Makefile

make
gcc -I. -I. -I/usr/lib/ruby/1.8/i686-linux -I. -D_FILE_OFFSET_BITS=64  -fPIC -fno-strict-aliasing -g -g -O2  -fPIC   -c win32/api.c
win32/api.c:2:21: fatal error: windows.h: No such file or directory
compilation terminated.
make: *** [api.o] Error 1


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/win32-api-1.4.8 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/win32-api-1.4.8/ext/gem_make.out
root@kelley-VirtualBox:/home/kelley#

उत्तर:

उत्तर № 1 के लिए 4

की ओर देखने के लिए उबुन्टु प्रलेखन। एक व्यापक, चरण-दर-चरण मार्गदर्शिका है जिसका आप अनुसरण कर सकते हैं।

ऐसा लगता है waitr केवल Windows है प्रयत्न sudo gem install watir-webdriver