/ / ubuntu ruby ​​gem नहीं मिला - माणिक, माणिक, स्थापित, ubuntu-12.04

ubuntu ruby ​​मणि नहीं मिला - रूबी, rubygems, स्थापित, ubuntu-12.04

मैं Ubuntu Precise के साथ rbgccxml का उपयोग करना चाहता हूं। इस रत्न के लिए नोकगिरी की आवश्यकता होती है। इस प्रकार, मैंने पहले रूबी-नोगोगिरी (v1.5.0) उबंटू पैकेज स्थापित किया। फिर मैंने "मणि स्थापित" के माध्यम से rbgccxml स्थापित करने की कोशिश की, लेकिन यह हमेशा nokogiri (> 1.4) को भी स्थापित करने की कोशिश करता है। इसे रोकने के लिए मैंने "मणि स्थापित - संकेत-निर्भरता rbgccxml" का उपयोग किया।

$ gem which rbgccxml
/var/lib/gems/1.8/gems/rbgccxml-1.0.3/lib/rbgccxml.rb
$ gem which nokogiri
/usr/lib/ruby/vendor_ruby/nokogiri.rb

अब मुझे अजीब व्यवहार होने लगा। निम्नलिखित स्क्रिप्ट:

require "nokogiri"
puts "step 1"
require "rubygems"
puts "step 2"
require "rbgccxml"
puts "step 3"

आउटपुट:

step 1
step 2
/usr/lib/ruby/vendor_ruby/1.8/rubygems/dependency.rb:247:in `to_specs": Could not find nokogiri (~> 1.4.0) amongst [rbgccxml-1.0.3] (Gem::LoadError)
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/specification.rb:771:in `activate_dependencies"
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/specification.rb:760:in `each"
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/specification.rb:760:in `activate_dependencies"
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/specification.rb:744:in `activate"
from /usr/lib/ruby/vendor_ruby/1.8/rubygems.rb:209:in `try_activate"
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:58:in `require"
from test3.rb:8

तो, क्यों नोगोगिरी की आवश्यकता के अनुसार पाया जाता है, लेकिन आरबीजीसीएक्सएमएल के अंदर की आवश्यकता नहीं है?

उत्तर:

उत्तर № 1 के लिए 1

rbgccxml निर्भरता को निर्दिष्ट करता है nokogiri का उपयोग करते हुए निराशावादी संस्करण की कमी निम्नलिखित नुसार:

gem "nokogiri", "~>1.4.0"

यह बराबर है:

gem "nokogiri", ">= 1.4.0", "< 1.5.0"

इस का मतलब है कि rbgccxml आपके द्वारा स्थापित किए जाने से पहले नोकोगिरी के संस्करण की आवश्यकता होती है।

यदि आपको विशेष रूप से नोकगिरी 1.5.0 की आवश्यकता नहीं है, तो रूबीज को हल करने दें और आपके लिए निर्भरताएं स्थापित करें।