/ / मणि स्थापित है, लेकिन jekyll प्लगइन इसे खोजने में असमर्थ है - माणिक, jekyll

मणि स्थापित लेकिन jekyll प्लगइन इसे खोजने में असमर्थ - rubygems, jekyll

मैं jekyll के लिए कम प्लगइन स्थापित कर रहा हूं, लेकिन इस फाइल को _plugins फ़ोल्डर में रख रहा हूं: https://gist.github.com/joshbrown/760265

मै भाग चुका: सुडोल रत्न कम स्थापित करें

मैंने सत्यापित किया है कि मणि का उपयोग करके स्थापित किया गया है मणि की सूची : कम (2.6.0)

दौड़ा रत्न एंव रत्नदिर : /usr/local/lib/ruby/gems/2.4.0

मणि जो "कम" : /usr/local/lib/ruby/gems/2.4.0/gems/less-2.6.0/lib/less.rb

हालाँकि मैं इसका उपयोग नहीं कर पा रहा हूँ बंडल शो --पथ

जब मैं इसे चलाता हूं, तो यह शिकायत करता है कि मणि स्थापित नहीं की गई है:

You are missing the library required for less. Please run:
$ [sudo] gem install less
Conversion error: Jekyll::LessConverter encountered an error while converting "aa.less":
uninitialized constant Jekyll::LessConverter::FatalException Did you mean? SignalException
jekyll 3.5.1 | Error:  uninitialized constant Jekyll::LessConverter::FatalException

मैक संस्करण: एल कैपिटन

क्या कोई मुझे बता सकता है कि मैंने कहाँ गलत किया?

उत्तर:

उत्तर № 1 के लिए 1

जैसा कि आप बंडल का उपयोग कर रहे हैं, आपको इसे जोड़ने की आवश्यकता है Gemfile मणि निर्भरता के रूप में।

तो भागो bundle install और आप इसे देख पाएंगे bundle show और Jekyll के साथ दौड़ें bundle exec jekyll serve.