/ / Retrocedere da Ruby 2.2.2 a Ruby 2.1.6 - ruby-on-rails, ruby

Retrocedere da Ruby 2.2.2 a Ruby 2.1.6 - ruby-on-rails, ruby

Sono uno sviluppatore di Rails per principianti e ho continuato a riscontrare questo problema quando ho provato a eseguire "rails server" sul prompt dei comandi, continuo a ricevere un errore:

"in" require ": impossibile caricare tale file - nokogiri / nokogiri (LoadError)"

Ho cercato online e apparentemente nokogiri non è attualmente supportato per Ruby 2.2.2 (la versione che sto attualmente utilizzando).

Attualmente sto lavorando in Ruby 2.2.2, Rails 4.2.3 e gem v. 2.4.8 su un PC Windows 8.1.

C'è qualcosa che posso fare per eludere questoproblema? In questo momento, sto pensando che il modo più semplice sarebbe quello di passare a Ruby 2.1.6 e andare da lì. Qualcuno sarebbe disposto a dirmi solo come farlo? Ho usato RubyInstaller ma non so se installare Ruby 2.1.6 in cima a Ruby 2.2.2 farebbe casino nel mio sistema. C'è un modo per eseguire automaticamente il downgrade di qualcosa?

Grazie in anticipo e se c'è un altro modo più semplice oltre al downgrade per favore fatemelo sapere!

Post scriptum Ho provato a declassare la versione gem e poi mi sono reso conto che in realtà non cambia la versione di Ruby.

risposte:

0 per risposta № 1

È possibile solo eliminare la cartella 2.2.2 è stata installata e reinstallare la versione precedente. Basta ricontrollare la variabile PATH se punta correttamente al percorso rubino reinstallato.