/ / Impossibile attivare susy-2.1.1, perché sass-3.2.14 è in conflitto con sass (~> 3.3.0) - sass, gruntjs, compass-sass, susy-sass

Impossibile attivare susy-2.1.1, perché sass-3.2.14 è in conflitto con sass (~> 3.3.0) - sass, gruntjs, compass-sass, susy-sass

Un po 'di confusione su questo messaggio che trovo. Windows 7 usando I am.

Running "compass:dev" (compass) task
Gem::LoadError on line ["2064"] of C: Unable to activate susy-2.1.1, because sass-3.2.14 conflicts with sass (~> 3.3.0)
Run with --trace to see the full backtrace

Attraverso il grugnito usando questo io sono.

Pacchetti attualmente:

Sass 3.2.14
Compass 0.12.3 (Alnilam)
susy susy-2.1.1

Come posso sbarazzarmi di questi messaggi.

risposte:

3 per risposta № 1

Susy 2 richiede Sass 3.3, che è supportato solo da Compass 1.0 (attualmente una pre-release). Se vuoi aggiornare Susy, devi aggiornare anche Compass.