/ / Lo strumento per i webmaster di Google rileva errori nella sitemap? - sitemap, robots.txt, google-webmaster-tools

Lo strumento webmaster di Google rileva errori nella sitemap? - sitemap, robots.txt, google-webmaster-tools

Ho una sitemap simile a questa:

<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:geo="http://www.google.com/geo/schemas/sitemap/1.0">

<url>

<loc>http://www.MyApp.se</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>daily</changefreq>
<priority>1.0</priority>
<url>

<loc>http://www.MyApp.se/Ad/Edit</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Site/Faq</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Site/Support</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Site/AboutMyApp</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Site/News</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Site/Cookies</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>
</url>
<url>

<loc>http://www.MyApp.se/Ad/Detail?id=283</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Ad/Detail?id=284</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Ad/Detail?id=285</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Ad/Detail?id=286</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>
<url>

<loc>http://www.MyApp.se/Ad/Detail?id=294</loc>
<lastmod>2012-06-28</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>
</urlset>

E questo è il mio Robo.txt:

User-agent: *
Disallow:
Sitemap: <http://www.MyApp.se/Site/Sitemap/>

Il problema è che nello strumento Webmaster di Google ottengo i seguenti errori:

1
Warning
Invalid XML-tagg
This tag could not be identifyed.
**Problems :** 6
Tag: url
**Row :** 7
Tag: url
13
Tag: url
**Row :** 19

2
Warning
Webadress blocked by robots.txt.
Sitemap contains webadresses that is blocked by robots.txt.
**Problems :** 12
Value : http://www.MySite.se
Value: http://www.MySite.se/Ad/Detail?id=283
Value: http://www.MySite.se/Ad/Detail?id=284

Perché? Ho costruito la mappa del sito in base alle guide su internet?

risposte:

2 per risposta № 1

OK, il <url> i tag sono dappertutto. Tutto dall'apertura <loc> tag alla chiusura </priority> tag per ogni pagina del sito web deve essere racchiuso all'interno di un insieme di <url> tag. Vedere il codice modificato di seguito:

<?xml version="1.0" encoding="utf-8"?>
<urlset
xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">

<url>
<loc>http://www.MyApp.se</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>daily</changefreq>
<priority>1.0</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Edit</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Site/Faq</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Site/Support</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Site/AboutMyApp</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Site/News</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Site/Cookies</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Detail?id=283</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Detail?id=284</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Detail?id=285</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Detail?id=286</loc>
<lastmod>2012-06-26</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Detail?id=294</loc>
<lastmod>2012-06-28</lastmod>
<changefreq>weekly</changefreq>
<priority>0.5</priority>
</url>

</urlset>

Solo per riordinare il tuo robots.txt file, fallo apparire come sotto. Assicurati che il Sitemap dichiarazione link alla posizione del tuo sitemap.xml file:

User-agent: *
Sitemap: http://point-this-to-your-sitemap.xml

Non c'è nemmeno bisogno di un vuoto Disallow dichiarazione.

Questa è la struttura di base che seguo per i siti Web che sviluppo, quindi dovrebbe andare bene!


0 per risposta № 2

Guardando l'inizio del tuo file, sembra che tu abbia un problema con i tag XML, sembra che tu abbia dimenticato un dopo il primo blocco. Hai :

     <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:geo="http://www.google.com/geo/schemas/sitemap/1.0">

<url>

<loc>http://www.MyApp.se</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>daily</changefreq>
<priority>1.0</priority>
<url>

<loc>http://www.MyApp.se/Ad/Edit</loc>

[...]

E dovresti avere:

     <urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9" xmlns:geo="http://www.google.com/geo/schemas/sitemap/1.0">

<url>
<loc>http://www.MyApp.se</loc>
<lastmod>2012-06-29</lastmod>
<changefreq>daily</changefreq>
<priority>1.0</priority>
</url>

<url>
<loc>http://www.MyApp.se/Ad/Edit</loc>

[...]

Penso che tu abbia lo stesso problema da qualche altra parte nel tuo codice. Potresti provare a utilizzare un editor XML per verificare.