/ / iPhone / XCode: Kierowanie na właściwy iPhone OS - iphone, xcode

iPhone / XCode: Kierowanie na właściwy iPhone OS - iphone, xcode

Tło: Mam XCode 3.2.3 zainstalowane i chcesz rozpowszechniać projekt, najlepiej na różnych urządzeniach iPhone (iPod Touch?), W tym starszych. Wybierając Project -> Build -> Base SDK I widzę opcje "iPhone Device 4.0" i "iPhone Device 3.2" (nie więcej 3.1.x, chociaż IIRC znajdował się w poprzedniej wersji XCode, zanim pobrałem najnowszy po iOS4).

Pytanie: Jak mogę ustawić cel wdrożenia, aby powiedział iPhone OS 3.0 lub 3.1? A co mam zrobić?

(Przeczytałem kilka poprzednich pytań i odpowiedzi związanych z StackOverflow na podobne tematy, ale nadal jestem zdezorientowany.) Dzięki!)

Odpowiedzi:

2 dla odpowiedzi № 1

Ustaw Base SDK na 4.0 i Cel wdrożenia do wersji 3.0. Dopóki nie będziesz używać żadnej z nowych funkcji 4.0, Twoja aplikacja będzie działać poprawnie na urządzeniu 3.0 lub uzyskaj kopię SDK 3.0 / 3.1 (jeśli możesz go znaleźć, nie wiem, czy Apple je wszystkie utrzymuje do pobrania gdzieś) i zainstalować go w osobnym katalogu.