/ / Konwencja nazewnictwa dla metody, która włącza / wyłącza lub aktywuje / dezaktywuje - cel-c, konwencje nazewnictwa

Konwencja nazewnictwa dla metody, która włącza / wyłącza lub aktywuje / dezaktywuje - cel-c, konwencje nazewnictwa

Aktualnie pracuję nad obiektywnym projektem c,i mają metodę, która włącza / wyłącza OR w innym terminie: aktywuje / dezaktywuje globalny serwer proxy HTTP. Zastanawiałem się, jaka jest najlepsza konwencja nazewnictwa dla takiej metody. Metoda ma argument BOOL, aby zdecydować, która operacja ma zostać wykonana, tj .: włączyć LUB wyłączyć. Jest to pytanie o stylu, które jest istotne dla większości języków programowania i zdecydowałem, że bardzo bym chciał wejść na tę wielką społeczność w tej sprawie, która z jakiegoś powodu mi przeszkadza.

Czy to jest dobre ? cokolwiek lepszego lub czystszego?

-(BOOL) activate:(BOOL) theActivateFlag;

lub

-(BOOL) enable:(BOOL) theEnableFlag;

Czy wywołanie [proxyObj activate: NO] OR [proxyObj enable: NO] należy rozumieć jako dezaktywację proxy?
Dzięki :)

Odpowiedzi:

0 dla odpowiedzi № 1

lubię Formularz w celu odzwierciedlenia funkcjonować w moim kodzie

Na górze pliku umieściłem

#define DISABLED NO
#define ENABLED YES

i mam moją funkcję

- (void)toggleProxyAs:(BOOL)state {
// assuming enabled is property/instance variable
enabled = state;
}

i używaj go jako

[myProxyObj toggleProxyAs:ENABLED];

Nie jest to standardowy sposób robienia rzeczy, ale dla mnie jest jaśniejszy i eliminuje potrzebę stosowania oddzielnych aktywatorów / dezaktywatorów.


2 dla odpowiedzi nr 2

Apple korzysta z enabled własność w ich własnych klasach:

@property (nonatomic, getter = isEnabled) BOOL enabled;

To tworzy następujący program pobierający i ustawiający:

- (BOOL)isEnabled {
return enabled;
}

- (void)setEnabled:(BOOL)flag {
enabled = flag;
}

Możesz też dać swojemu proxy parę activate i deactivate metody lub enable i disable metody.


1 dla odpowiedzi nr 3

Myślałem (po tym, jak o tym pomyślałem i kilka razy zmieniłem zdanie) ...

-(BOOL) enableProxy:(BOOL)shouldEnable;

...Miałoby to więcej sensu, chociaż byłbym pierwszym, który przyznałby się, że od czasu do czasu tarzam się w ciemnych pestkach nazewnictwa konwenansów (ściany pokryte błędnie wyrażonymi nazwami funkcji i metod), więc być może nie jestem w stanie najlepiej odpowiedzieć na to pytanie. :-)