/ / dlaczego otrzymuję "nie mogłem znaleźć loków z klejnotami lokalnie ..." podczas próby aktualizacji InstantRails2.0 do szyn 2.3? - ruby-on-rails

dlaczego otrzymuję "nie mogłem znaleźć loków z klejnotami lokalnie ..." podczas próby aktualizacji InstantRails2.0 do szyn 2.3? - ruby-on-rails

Pełny komunikat o błędzie to "could not find railsgem lokalnie lub w repozytorium ". Przeczytałem wiki Rails o aktualizacji szyn i nie ma żadnych informacji na temat tego błędu." Jestem uruchomiony na WinXP. The Rails Wiki powiedział, że muszę najpierw zrobić update_rubygems i wygląda na to, że udało mi się to zrobić z powodzeniem. Moja rubinowa wersja to 1.8.6. Przeanalizowałem ten konkretny błąd i zdobyłem kilka haseł dotyczących upewnienia się, że źródłem informacji o klejnotach są gems.rubyonrails.org, które moje robi.

Jakieś sugestie? Jakie inne informacje o środowisku muszę podać?

Czy istnieje sposób na pobranie i zainstalowanie najnowszej wersji szyn, jeśli nadal występują problemy?

Odpowiedzi:

0 dla odpowiedzi № 1

Nie jestem zaznajomiony z poręczami, ale wygląda na to, że nie był aktualizowany od czasów rails 2.0.

Tutaj jest link do kogoś który miał podobny problem i rozwiązał go w końcu instalując szyny z github.

Jeśli to nie zadziała, minęło trochę czasuOpracowałem Railsy w oknach, ale jeśli zaktualizujesz swoją wersję klejnotów ruby ​​(również opisanych w linku), to następujące czynności powinny działać zarówno w przypadku instalowania, jak i aktualizacji szyn:

gem install rails

Jeśli to nie działa, odinstaluj Instant Rails i zainstaluj na podstawie windows zainstaluj instrukcje na wiki rails. To przygotuje Cię do rozwoju naWindows box za pomocą sqlite i wbudowanego serwera, który jest dostarczany z Railsami (WEBrick lub kundel jeśli zainstalujesz gem). Nie potrzebujesz ani nawet nie chcesz używać ciężkich dysków twardych i serwerów do rozwoju - tylko kłopotów.

Jeśli masz zamiar używać systemu Windows jako platformy serwerowej, sprawy stają się nieco trudniejsze. Zrobiłem to przez jakiś czas kilka lat temu, ale to był taki ból, który był częścią tego, dlaczego nauczyłem się Linuksa i tak było dobrze Warto było. Kiedy zrobiłem to w systemie Windows, użyłem XAMPP zainstalować mySQL i Apache.